Release Notes‎ > ‎

Supported Platforms

This page includes the installation requirements, supported platforms, and system requirements for Live API Creator.

Installation Requirements

Live API Creator supports the following software and hardware installation requirements:

Important! Maintain the minimum requirements for a host machine running Live API Creator.

RequirementMinimum
NetworkingIPv4 or IPv6 interface
ProcessorOne or more core processors, 2 GHz or faster.

Recommended: Dual-core processor

Memory1 GB with 400 MB Java heap size
Recommended: 8 GB or higher
Operating Systems
A dedicated server running one of the following:
  • Redhat Enterprise Linux 6.0 and higher
  • CentOS 6.5 or higher
  • Windows 7
  • Windows 8
  • Microsoft Windows Server 2008
  • Microsoft Windows Server 2012
  • Mac OSX 10.10
  • Amazon Linux 3.14
You can deploy in Amazon Web Services (AWS) environment, including AWS Elastic Beanstalk.
Admin Databases
  • MySQL
    • Supported: MySQL 5.6.x with root user and password
    • Tested: 5.6.23
  • MariaDB
    • Supported: 10.x with root user and password
    • Tested: 10.1 
    • 500 MB for tablespace (1 - 10 GB recommended)
  • PostgreSQL 9.0 or higher
  • Apache Derby/JavaDB 10.8 or higher

You can run Live API Creator with an embedded JavaDB database for demonstration and evaluation purposes. MySQL and MariaDB are not required for these purposes.

Java
  •  Java SE Development Kit (JDK) 1.8.0 u40
  • OpenJDK 1.8 and higher
Java Containers
  • Apache Tomcat 7 and 8
  • Java Servlet Container: Apache Tomcat 7.x (tested 7.0.64) or Tomcat 8.x (tested 8.0.28)
  • Jetty 8
  • Glassfish 4.0
Runtime EnvironmentNode.js 4.x


Supported Data Sources

Databases

Live API Creator supports the following databases:

 Database Supported Versions
IBM DB2 for z/OS
10.5
IBM DB2 for Linux, Unix, and Windows10.5
MySQL5.5.36 or higher
5.6.19 or higher
MariaDB, Amazon Aurora, and other 100% MySQL-compatible databases 
Oracle11g or higher
Microsoft SQL Server 201211.0
Microsoft SQL Server 2008R2 or higher
PostgreSQL9.0 or higher
NuoDB2.0 or higher
Apache Derby/JavaDB10.8 or higher
MongoDB2.4 or higher

Drivers

Live API Creator supports the following database drivers:

Database driverVersion
IBM DB2 JDBC driver10.5fp7 and 11.1
Note: This driver supports IBM DB2 for z/OS and IBM DB2 v10.5 for Linux, Unix, and Windows.
MySQL JDBC driver5.1.26
MariaDB JDBC driver1.2.3
Microsoft SQL Server JDBC driver4.0
PostgreSQL JDBC driver9.4
JavaDB/Derby driver10.12
NuoDB JDBC driver1.0

API Documentation

Live API Creator supports the following version of the Swagger specification for defining REST APIs:

ProductVersion
Swagger2.0

Web Browsers

Live API Creator supports the following web browsers:

  • Google Chrome
  • Safari
  • Internet Explorer 11
  • Firefox

Use the latest production-level versions of this browser whenever possible.